Monday, December 18, 2017

Lirik Lagu Laoneis Band - Ayah


Seven -  Lirik Lagu Laoneis Band - Ayah

Ayah ku kirimkan doa
Semoga engkau tenang di alam syurga
Ayah kan ku ingat selalu
Pengorbanan yang telah engkau berikan

Ayah terlalu cepat kau pergi
Meninggalkan aku sendiri
Ayah tak bisa aku ingkari
Tanpa engkau hidupku terasa sunyi

Ayah dengarkanlah

Dan teringat saat kepergianmu
Ku taburi bunga mawar untukmu
Dan berdoa untuk melepaskanmu
Ayah berlinang air mataku

Ayah terlalu cepat kau pergi
Meninggalkan aku sendiri
Ayah tak bisa aku ingkari
Tanpa engkau hidupku terasa sunyi

Ayah dengarkanlah

Dan teringat saat kepergianmu
Ku taburi bunga mawar untukmu
Dan berdoa untuk melepaskanmu
Ayah berlinang air mataku, berlinang air mataku

Ayah tak bisa aku ingkari
Tanpa engkau hidupku terasa sunyi

Saturday, November 25, 2017

Load Balance Metode ECMP

Seven - Load balance dengan metode ECMP (Equal Cost Multi-Path) merupakan improvisasi dari metode round robin load balance.  Load balance sendiri merupakan teknik untuk menggabungkan koneksi internet lebih dari satu. Contoh topologi : 



Saya akan mencoba membahas load balance ECMP dengan 2 line koneksi internet. Setting awal sama seperti kita setting router agar router dan client dibawah router bisa terkoneksi ke internet. Karena ada 2 line koneksi internet, maka akan ada 2 rule NAT masquerade. 




Setelah setting standart koneksi ke internet selesai, selanjutnya kita bisa mulai setting Load balance ECMP. Caranya cukup mudah, kita tinggal menambahkan rule default gateway dengan dst-address = 0.0.0.0 dan gateway=ISP A,ISP B




Ini adalah tipikal ECMP (Equal Cost Multipath) gateway dengan check-gateway. ECMP merupakan "persistent per-connection load balancing" atau "per-src-dst-address combination load balancing". Begitu salah satu gateway unreachable atau terputus, check-gateway akan menonaktifkan gateway tersebut dan menggunakan gateway yang masih aktif, sehingga kita bisa mendapatkan efek "failover". 

Jika kita memiliki line koneksi internet dengan kecepatan bandwidth yang berbeda, kita bisa membuat perbandingan untuk membagi beban. Misal kita punya bandiwdth ISP A: 2 MBps dan ISP B: 4 MBps. Jika dibuat perbandingan, maka menjadi 1:2.




Dengan adanya lebih dari satu gateway, terkadang menimbulkan masalah baru pada router. Yaitu ke gateway mana router akan terkoneksi. Contoh kasus adalah ketika ada paket masuk ke router (incoming) yang berasal dari luar (Internet), trafik respon dari router (outgoing) akan terkena loadbalance juga. Sehingga paket respon untuk request yang diterima dari interface "Eth 1 - ISP A", bisa jadi dikirim melalui interface "Eth 2 - ISP B". Untuk menghindari hal tersebut, kita perlu membuat aturan routing agar koneksi outgoing router tetap melalui interface yang sama dengan interface trafik incomingnya.


/ip firewall mangle
add chain=input in-interface=Eth 1 - ISP A action=mark-connection new-connection-mark=ISP-A_conn
add chain=input in-interface=Eth 2 - ISP B action=mark-connection new-connection-mark=ISP-B_conn
add chain=output connection-mark=ISP-A_conn action=mark-routing new-routing-mark=ke_ISP-A
add chain=output connection-mark=ISP-B_conn action=mark-routing new-routing-mark=ke_ISP-B 
/ip route
add dst-address=0.0.0.0/0 gateway=10.9.8.1 routing-mark=ke_ISP-A
add dst-address=0.0.0.0/0 gateway=172.16.15.1 routing-mark=ke_ISP-B


Known Issues


Masalah DNS
Permasalahan yang sering timbul adalah ketika kita melakukan setting DNS dengan DNS dari salah satu ISP. Kemungkinan DNS dari salah satu ISP ada setting khusus dimana hanya mengijinkan koneksi dari jaringan ISP itu saja. Maka ketika koneksi ISP tersebut down, koneksi DNS melalui ISP kedua tidak dapat berjalan. Untuk mengatasi hal tersebut, kita bisa menggunakan open DNS, seperti DNS publik Google 8.8.8.8.

Routing table flushing
Setiap saat ketika sesuatu memicu flush tabel routing, maka cache ECMP juga akan di flush. Koneksi akan diarahkan ke gateway sekali lagi dan mungkin atau mungkin juga tidak diarahkan pada gateway yang sama. (Jika 2 gateway ada kemungkinan 50% trafik akan mulai mengalir melalui gateway lain).

Jika Anda memiliki jaringan yang di routing sepenuhnya (ip address klien dapat diarahkan melalui semua gateway yang ada), perubahan gateway tidak akan berdampak buruk, namun jika Anda menggunakan masquerade, perubahan gateway akan menyebabkan perubahan alamat dan koneksi sumber paket dan koneksi akan di drop.

Flush tabel routing dapat disebabkan oleh 2 hal:
1) perubahan tabel routing (pembaruan protocol routing dinamis, perubahan oleh pengguna)
2) setiap 10 menit tabel routing di flush untuk alasan keamanan (untuk menghindari kemungkinan serangan DoS)

Jadi, meski Anda tidak melakukan perubahan tabel routing, koneksi bisa beralih ke gateway lain setiap 10 menit

Referensi:
https://wiki.mikrotik.com/wiki/ECMP_load_balancing_with_masquerade
http://www.mikrotik.co.id/artikel_lihat.php?id=76

Wednesday, November 22, 2017

Lirik Lagu Tiada Kata Terucap


Seven - Lirik Lagu Tiada Kata Terucap, vocal : Tasya Rosmala feat Gery Mahesa, cipta : Roby Jembuk

Tiada kata yang terucap
Bila engkau cinta padaku
Sekian lama ku berharap
Samun engkau diam membisu

Cinta bukan cuma dikata
Manis dibibir tiada guna
Sesungguhnya rasa itu ada
Tumbuh abadi dalam jiwa

Indah ungkapan yang terngiang
Lembut menyentuh bak gurindam
Hasrat dan cinta yang dipendam
Bagai langit yang tak berbintang

Tega nian
Mengapa kau tak pernah bilang

Tak ingin engkau menyesal
Hidup dalam penderitaan

Maaf sayang
Cintaku kini telah hilang

Aku rela demi Tuhan
Bila kau dipersunting orang

Haaaaaaa
Hmmmmmmm
Haaaaaaa
Aaaa

Kita tiada berdaya

Tiada kata yang terucap
Bila engkau cinta padaku
Sekian lama ku berharap
Samun engkau diam membisu

Cinta bukan cuma dikata
Manis dibibir tiada guna
Sesungguhnya rasa itu ada
Tumbuh abadi dalam jiwa

Indah ungkapan yang terngiang
Lembut menyentuh bak gurindam
Hasrat dan cinta yang dipendam
Bagai langit yang tak berbintang

Lirik Lagu Kanggo Kowe Vocal Tasya Rosmala


Seven -  Lirik Lagu Kanggo Kowe, vocal: Tasya Rosmala, cipta: Jo Klithik

Opo wes sak mestine
Aku kudhu koyo ngene
Bebarengan karo kowe
Urip sak bendinane

Saben kepethok
Kowe kondho yen kowe tresno
Aku percoyo ra ono wong wadon liyo

Aku neng kene
Kowe sing ono nang kono
Aku tak kondo
Mugo biso mbok tompo

Saben ngabari
Kowe mesti loro ati
Aku ra ngerti
Mergo sopo sing njalani

Kowe lan aku
Wes sumpah ing janji
Ora bakal nggudo ati

Yo mung sawiji
Sing nang njero ati
Tresno iki
Yo mung kowe sing tak tresnani

Monday, November 20, 2017

Mengenal Ukuran Rackmount

Seven - Rackmount merupakan casing berbentuk tipis, pipih horizontal dan dapat disusun layaknya sebuah rak pada sebuah lemari khusus.

Author: Victorgrigas / Rackmount pada server wikimedia

Ukuran rackmount berkisar antara :
UnitDimension (W x H x D)
1U19″ x 1.75″ x 17.7″; 19″ x 1.75″ x 19.7″; 19″ x 1.75″ x 21.5″
2U19″ x 3.5″ x 17.7″; 19″ x 3.5″ x 20.9″ ;19″ x 3.5″ x 24″
3U17.1″ x 5.1″ x 25.5″
4U19″ x 7″ x 17.8″; 19″ x 7″ x 26.4″
5U19″ x 8.34″ x 19.67″; 19.1″ x 8.75″ x 26.4″
6U19″ x 10.5″ x 19.5″
7U17″ x 12.2″ x 19.8″
Pada sistem rackmount merupakan istilah yang merepresentasikan jumlah unit server yang bisa dipasang pada rak server, yaitu 1U, 2U, 3U atau 4U. 1U sendiri melambangkan ketebalan (tinggi) server dalam satuan inchi, 1U =  1.75 inchi (44.5mm).
Dengan sistem rackmount maka pengaturan server yang berjumlah lebih dari 2 unit atau lebih akan tertata dengan baik. Rackmount umumnya dipakai institusi yang menggunakan fungsi server berbeda pada satu rak, seperti Web Server, Database Server, dan sebagainya.

Referensi:
https://gemaroprek.com/mengenal-rack-rerver-dan-ukuran-rackmount/
https://members.idcolo.com/knowledgebase/71/Mengenal-Ukuran-Rackmount-1U-2U-3U-4U-dll.html
https://commons.wikimedia.org/wiki/File:Wikimedia_Foundation_Servers-8055_08.jpg (sumber gambar)

Sunday, November 19, 2017

Lirik Lagu PENDHOZA - Aku Cah Kerjo


Seven -  Lirik Lagu PENDHOZA - Aku Cah Kerjo 

Bebasan nunggu mongso rendeng
Anggongku leh ngenteni kowe
Wes ono sesasi genep dino iki

Mas yen pancen tresnoku iki
Mbok anggep ra ono gunane
Aku ra kuciwo lan aku ra loro

Dek lungaku ra keget cidro
Aku lagi pengen mikir kerjo
Tak jaluk kowe ojo keloro-loro

Dek tresnaku mung siji kowe
Langit bumi kang dadi seksine
Yen neng ati ra ono wanito liyo

Kowe rasah sok mutusi, aku ra neng endi-endi
Aku lungo amung golek rejeki

Pangapurane awakku ra tau nyanding sliramu
Mergo tuntutan kerjoku nganti ora nduwe wektu
Wektu kanggo ngancani ugo ngeterke nyanyi
Kowe kudu ngerti lungaku golek rejeki

Dongakno lakuku ngayahi kewajibanku
Senajan abot kanggomu nanging kuatno atimu
Wes dadi kahanan aku lungo adoh paran
Ora bakal kelegan nyanding wedokan liyan

Dek lungaku ra keget cidro
Aku lagi pengen mikir kerjo
Tak jaluk kowe ojo keloro-loro

Dek tresnaku mung siji kowe
Langit bumi kang dadi seksine
Yen neng ati ra ono wanito liyo

Ojo keloro-loro lungaku ra keget cidro
Opo meneh nganti mikir aku wes ora tresno
Yo mung kowe sing tansah ono neng njero dodo
Ra ono trensno liyo mergo aku tansah setio

Kudu percoyo tresnoku iki mung siji kowe
Wani sumpah mati neng ati ra ono liyane
Janjiku tak buktekke ora mung ono lambe
Tunggunen baliku bebrayan tekane sak lawase

Dek lungaku ra keget cidro
Aku lagi pengen mikir kerjo
Tak jaluk kowe ojo keloro-loro

Dek tresnaku mung siji kowe
Langit bumi kang dadi seksine
Yen neng ati ra ono wanito liyo

Kowe rasah sok mutusi, aku ra neng endi-endi
Aku lungo amung golek rejeki

Anggonku ngabari yo mung lewat bbm-an
Kadang sinyal angel marai dadi penghalang
Neng yo kudu sabar, ora usah nggo nesunan
Mergo trenso kui mestine akeh pacoban

Sing tak jaluk kowe ojo nganti ilang roso
Senajan aku kerep gawe gelo lan kuciwo
Jembarno atimu sak jembare laut samudro
Kowe kudu ngerti yen aku iki cah kerjo

Mas yen pancen kuwi karepmu
Aku yo mung tansah biso nunggu
Tak kuatne atiku tanpo sliramu

Mas nadyan kowe lungo kerjo
Sing tak jalu kowe tetep setio
Ojo nganti kegudho wanito liyo

Sabaro aku yo mung cah kerjo



Friday, November 3, 2017

Lirik Lagu Pria Idaman - Rita Sugiarto


Seven - Lirik Lagu Pria Idaman - Rita Sugiarto, cover Tasya Rosmala

Sikapmu yang penuh kasih dan sayang
Membuat aku hai mabuk kepayang
Sifatmu yang peramah dan pendiam
Membuat aku rindu siang-malam

Juga wajahmu yang teramat tampan
Akan selalu jadi perhatian
Sungguh kau seorang pria idaman
Idamannya gadis sepanjang zaman

Sungguh sukar dicari masa kini
Orang sepertimu pria sejati
Bagaimana aku tak bahagia
Berdampingan denganmu hai kekasih

Sopan-santunmu menyejukkan kalbu
Tutur-sapamu hai semanis madu
Bentuk tubuhmu lelaki perkasa
Kejujuranmu dapat dipercaya

Tuesday, July 25, 2017

Pengucapan Aamiin

Seven - Sudah benarkah ucapan “Aamiin” kita ???

Membaca/mengucapkan aamiin adalah dengan memanjangkan a (alif) dan memanjangkan min, apabila tidak demikian maka artinya akan menjadi lain. Dalam Bahasa Arab, ada empat perbedaan kata “AMIN” yaitu : 

1. ”AMIN” (alif dan mim sama-sama pendek), artinya AMAN, TENTRAM 

2. “AAMIN” (alif panjang & mim pendek), artinya MEMINTA PERLINDUNGAN KEAMANAN 

3. ”AMIIN” (alif pendek & mim panjang), artinya JUJUR TERPERCAYA

 4. “AAMIIN” (alif & mim sama-sama panjang), artinya YA TUHAN, KABULKANLAH DOA KAMI

Friday, July 21, 2017

Lirik Lagu Kasih Tak Sampai - Tasya Rosmala Ft. Gerry Mahesa




Penyanyi : GERRY MAHESA & TASYA

diiringi : OM. AURORA
judul lagu : Kasih tak sampai
Produksi : Perdana Record


Seven - Lirik Lagu Kasih Tak Sampai - Tasya Rosmala Ft. Gerry Mahesa. Cipt. Rony Jembluk
Voc. Tasya Rosmala - Gerry Mahesa

Gelora cinta di dadaku
bertuliskan namamu
alunan kata puisiku ku ukir di hatiku

begitu juga aku merasakan
ada benih cinta di hatiku
adakah jalan kasih tersampaikan
sementara dikau milik orang

alunan nada-nada cinta
menelusuri jiwa
mungkinkah kisah kasih kita
abadi tuk selamanya

bahagia rasa hatiku
bila ada di sisimu
bercumbu rayu memadu cinta
tuk melepaskan rindu

mengapa hati gelisah
pabila jauh darimu
aku pun sama gelisah selalu
bila jauh darimu

pantaskah kita bercinta
cinta kita terlarang
haruskah cuma berkhayal
karena dikau milik orang

Monday, July 17, 2017

Mengamankan MariaDB Server

Seven - Setelah anda menginstall MariaDB Server, hal yang direkomendasikan bahkan wajib dilakukan adalah mengamankan MariaDB Server Anda. Terutama jika digunakan dalam lingkungan produksi. Mengamankan server database MariaDB sangat mudah dilakukan. Dalam kasus saya, saya menggunakan OS Ubuntu Server. Untuk OS lainnya silahkan menyesuaikan.

Berikut langkah-langkah mengamankan server database MariaDB:

  1. Buka Terminal lalu jalankan perintah berikut "sudo mysql_secure_installation". (tanpa tanda kutip)
  2. Anda akan diminta memasukkan password root saat ini untuk melanjutkan. Tekan tombol enter jika tidak ada.
  3. Langkah selanjutnya Anda akan ditanya apakah Anda akan mengubah password root atau tidak. Ketik "Y" (tanpa tanda kutip) lalu enter untuk mengganti password root atau ketik "n" lalu enter untuk melewatinya tanpa mengganti password root.
  4. Selanjutnya adalah menghapus pengguna anonim. Ketik "Y" (tanpa tanda kutip) lalu enter untuk menghapus pengguna anonim atau ketik "n" lalu enter untuk tidak menghapus pengguna anonim. Sangat direkomendasikan untuk menghapus pengguna anonim!
  5. Pada langkah ini Anda akan ditanya untuk melarang pengguna root login ke server database MariaDB secara remot. Ketik "Y" (tanpa tanda kutip) lalu enter untuk melarang user root login via secara remot atau ketik "n" lalu enter untuk mengijinkan pengguna root login secara remot. Sangat direkomendasikan untuk melarang pengguna root login secara remot!
  6. Langkah selanjutnya adalah menghapus database "test" beserta hak akses ke database "test". Secara default ketika menginstall MariaDB database bernama "test" juga akan dibuat dan semua pengguna dapat mengaksesnya. Ketik "Y" (tanpa tanda kutip) lalu enter untuk menghapus database "test" beserta hak akses ke database "test". Sangat direkomendasikan untuk menghapus database "test", terutama jika digunakan dalam lingkungan produksi.
  7. Selanjutnya adalah memuat ulang tabel hak akses untuk memastikan perubahan yang dilakukan akan langsung diterapkan. Ketik "Y" (tanpa tanda kutip) lalu enter untuk memuat ulang tabel hak akses.
Berikut gambar langkah-langkah mengamankan server database MariaDB:

Securing MariaDB Installation.


Tentunya langkah-langkah diatas belum sepenuhnya membuat server database MariaDB Anda aman, diperlukan pemahaman pengetahuan lebih lanjut tentang keamanan cyber/cyber security Anda bisa berkonsultasi dengan ahli IT yang Anda percaya untuk melakukannya. Semoga bermanfaat.

Sunday, July 16, 2017

Lirik Lagu Pengantin Baru - Gerry Mahesa Ft. Tasya Rosmala


Seven - Lirik Lagu Pengantin Baru - Gerry Mahesa Ft. Tasya Rosmala

Malam bahagia
Kita semua turut bahagia
Sanak saudara handai tolan
Menyambut gembira

Pesta meriah pengantin baru
Duduk bersanding
Bagaikan raja
Bagaikan ratu

Malam bahagia
Kita semua turut bahagia
Sanak saudara handai tolan
Menyambut gembira

Ucapan selamat
Silih berganti
Sanjung dan puja
Tiada henti

Senyum menghias
Pengantin baru
Janji setia hidup semati

Semoga Tuhan
Melimpahkan rahmatnya
Pada mereka

Tuesday, May 16, 2017

Blok Ransomware WannaCry Pada Mikrotik

Seven - Berikut beberapa cara Blok Ransomware WannaCry Pada Mikrotik:

Filter Rule

Metode dengan firewall rule bekerja pada traffic dimana host berada berada dalam subnet/segment ip berbeda, baik antar koneksi lokal maupun dari publik/internet

/ip firewall filter add chain=forward protocol=tcp \
dst-port=137-139,445,3389 action=drop disabled=no comment="Drop Ransomware WannaCry" 
/ip firewall filter add chain=forward protocol=udp \
dst-port=137-139,445,3389 action=drop disabled=no comment="Drop Ransomware WannaCry"

Bridge Filter

Metode ini dapat diterapkan pada kondisi semua host berada dalam subnet/segment ip yang sama dan dalam kondisi bridging.

/interface bridge filter add chain=forward in-interface=ether1 \
mac-protocol=ip dst-port=137-139 ip-protocol=tcp action=drop disabled=no comment="Drop Ransomware WannaCry" 
/interface bridge filter add chain=forward in-interface=ether1 \
mac-protocol=ip dst-port=137-139 ip-protocol=udp action=drop disabled=no comment="Drop Ransomware WannaCry" 
/interface bridge filter add chain=forward in-interface=ether1 \
mac-protocol=ip dst-port=445 ip-protocol=tcp action=drop disabled=no comment="Drop Ransomware WannaCry" 
/interface bridge filter add chain=forward in-interface=ether1 \
mac-protocol=ip dst-port=445 ip-protocol=udp action=drop disabled=no comment="Drop Ransomware WannaCry"
/interface bridge filter add chain=forward in-interface=ether1 \
mac-protocol=ip dst-port=3389 ip-protocol=tcp action=drop disabled=no comment="Drop Ransomware WannaCry" 
/interface bridge filter add chain=forward in-interface=ether1 \
mac-protocol=ip dst-port=3389 ip-protocol=udp action=drop disabled=no comment="Drop Ransomware WannaCry"

Thanks to: http://www.mikrotik.co.id/artikel_lihat.php?id=250 

Thursday, May 4, 2017

Magma, Lava, dan Lahar

Seven - Magma, Lava, dan Lahar

Magma

Materi yang terbentuk di dalam mantel bumi (lempeng tektonik) berupa material lumpur yang berpijar pada suhu sangat tinggi (sampai dengan 1000 derajat Celcius), bersifat asam atau basa, dan mempu menghasilkan gaya endogen yang besar.  Terjadi akibat adanya gesekan/ tumbukan dua lempeng tektonik, sehingga menghasilkan suhu tinggi dan membentuk dapur magma yang mendorong keatas dan dapat memunculkan adanya gunung api.

Magma merupakan batu-batuan cair yang terletak di dalam kamar magma di bawah permukaan bumi. Magma di bumi merupakan larutan silika bersuhu tinggi yang kompleks dan merupakan asal semua batuan beku. Magma berada dalam tekanan tinggi dan kadang kala memancut keluar melalui pembukaan gunung berapi dalam bentuk aliran lava atau letusan gunung berapi.

Magma sebagai masa silikat cair pijar sangat giat melakukan gerakan ke segala arah baik secara vertical, miring, menyusup atau mendatar, yang bergerak dipermukaan bumi ataupun hanya di dalam bumi. Bagian bumi tempat keluarnya magma disebut gunung berapi, sedangkan gerakan magma yang dapat mengangkat lapisan batuan yang cembung ke atas dan mengikis ruangan yang gejala-gejala vulkanisme tersebut meliputi:

Instruksi Magma

Proses penerobosan magma ke dalam litosfer tetapi tidak mampu mencapai permukaan bumi. Intrusi magma menghasilkan bentukan-bentukan di dalam dapur magma.

  1. Batolit, yaitu magma yang membeku di dalam dapur magma.
  2. Lakolit, yaitu batuan beku yang terbentuk dari resapan magma dan membeku diantara dua lapisan batuan berbentuk lensa cembung.
  3. Sill/keeping intrusi, batuan beku yang berbentuk diantara dua lapisan batuan, berbentuk pipih dan melebar.
  4. Gang, yaitu magma yang memotong lapisan batuan dengan arah tegak/miring, berbentuk pipih dan melebar.
  5. Apofisa, yaitu batuan beku yang berbentuk dicabang-cabang gang, berukuran kecil.

    Ekstrusi Magma

    Gerakan magma mencapai permukaan bumi dalam bentuk letusan atau erupsi.erupsi dibedakan menjadi tiga macam sebagai berikut:

    1. Erupsi linear, yaitu keluarnya magma melalui retakan atau celah.
    2. Erupsi sentral, yaitu keluarnya magma melalui terusan kepundan.

      Magma dalam kerak Bumi dapat terbentuk sebagai akibat dari perbenturan antara 2 (dua) lempeng litosfer, dimana salah satu dari lempeng yang berinteraksi itu menunjam dan menyusup kedalam astenosfer. Sebagai akibat dari gesekan yang berlangsung antara kedua lempeng litosfer tersebut, maka akan terjadi peningkatan suhu dan tekanan, ditambah dengan penambahan air berasal dari sedimen-sedimen samudra akan disusul oleh proses peleburan sebagian dari litosfer

      Sumber magma yang terjadi sebagai akibat dari peleburan tersebut akan menghasilkan magma yang bersusunan asam (kandungan unsur SiO2 lebih besar dari 55%). Magma yang bersusunan basa, adalah magma yang terjadi dan bersumber dari astenosfir. Magma seperti itu didapat di daerah-daerah yang mengalami gejala regangan yang dilanjutkan dengan pemisahan litosfir.

      Lava

      Lava (“lava flow”): adalah magma yang keluar dari permukaan dan mengalir dipermukaan, bisa di darat, bisa di dasar laut. Ini adalah betul-betul material magma (cairan silikat) bersuhu tinggi, bisa mencapai 1300C. Hasil endapannya adalah batuan ekstrusif yang masif atau brecciated.

      Lava merupakan magma yang keluar dari perut bumi/ gunung api akibat adanya peningkatan aktifitas vulkanik di dalam gunung api. Lava keluar dapat berupa leleran yang mengalir menuruni lereng gunung hingga tempat yang jauh di lembah, magma bisa juga keluar dan berdiam disekitar puncak gunung api dan membentuk kubah lava (dome) sehingga gunung api tersebut kelihatan lebih tinggi (contoh pada gunung Merapi di Jawa tengah).

      Lahar

      Lahar yaitu materi Erupsi gunung api yang berbentuk padat mulai dari ukuran debu vulkanik sampai ukuran bongkah (Bomb) dan telah bercampur dengan air. Lahar keluar oleh letusan yang sifatnya explosif.

      Lahar Dingin


      Material gunung api hasil letusan yang masih belum terkonsolidasi akan berkumpul di puncak atau lereng sekitar kawah. Pada saat terjadi hujan maka bahan-bahan endapan piroklastik tersebut akan diangkut dan bergerak ke bawah sebagai aliran pekat dengan densitas tinggi. Bahan-bahan material tersebut berupa bongkah, bom vulkanik, lapili dan debu. Semua bahan tersebut akan melewati lereng atau lembah gunung api hingga jarak yang sangat jauh.

      Endapan lahar dingin memiliki ciri pemilahannya yang sangat buruk meski masih nampak adanya fragmen-fragmen yang besar dan berat akan berkumpul di bagian bawah endapan. Kadang endapan lahar dingin sulit dibedakan dengan endapan awan panas terutama jika sudah lama. Endapan lahar dingin dalam waktu lama akan menjadi aliran sungai baru.

      Lahar Panas


      Beberapa gunung api di Indonesia memiliki dasar kepundan yang bersifat kedap air sehingga sejumlah air hujan akan berkumpul dan membentuk danau, contohnya adalah G. Kelud, G. Galunngung dan G. Agung. Bahan lempung pembentuk dasar kepundan berasal dari ubahan batuan yang membentuk dinding kepundan oleh gas yang keluar dari pipa gunung api. Baha halus ini akan diangkut oleh hujan yang turun dan akan mengendap di dasar kepundan.

      Menurut catatan geolog Indonesia, G. Galunggung di Tasikmalaya Jawa barat pada tahun 1882 meletus dan memuntahkan seluruh danau beserta isinya yang sudah bercampur dengan magma. Akibatnya adalah terjadi aliran lahar panas yang mampu mencapai radius 60 km. Erupsi Kelud pada 1919 juga menghasilkan lahar panas dan merusak hingga 130 km persegi lahan pertanian. Salah satu upaya untuk mengantisipasi terjadinya bencan aliaran lahar panas tersebut adalah dengan membuat terowongan-terowongan untuk mengurangi volume air yang ada dalam kepundan sehingga ketika terjadi letusan tidak akan banyak mengeluarkan lahar.

      Thanks to :
      http://www.e-jurnal.com/2013/11/perbedaan-lava-lahar-dan-magma.html
      http://www.gosmuu.net/2016/10/perbedaan-magma-lava-dan-lahar.html

      Sunday, April 30, 2017

      Rumus-Rumus Dalam MySQL

      Seven - Rumus-Rumus Dalam Mysql


      1. Fungsi Agregaris/Agregates


      • AVG


      Menghitung rata-rata dari suatu kolom tertentu yang telah didefinisikan dalam perintah select.
      Sintak :
      SELECT AVG nama_kolom FROM nama_tabel [WHERE]
      Contoh:
      SELECT AVG (nilai) FROM mata_pelajaran


      • COUNT

      Untuk menghitung jumlah baris dalam tabel.
      Sintak :
      SELECT COUNT nama_kolom FROM nama_tabel [WHERE]
      Contoh :
      SELECT COUNT (*) FROM siswa
      SELECT COUNT (mata_pelajaran) FROM jadwal


      • MAX


      Untuk mengetahui nilai terbesar dari sebuah kolom tertentu dalam perintah select.
      Sintak :
      SELECT MAX (nilai) FROM mata_pelajaran


      • MIN

      Untuk mengetahui nilai terkecil dari sebuah kolom tertentu dalam perintah select
      Sintak :
      SELECT MIN nama_kolom FROM nama_tabel [WHERE]
      Contoh :
      SELECT MIN (nilai) FROM mata_pelajaran


      • SUM

      Untuk menjumlah suatu kolom tertentu yang telah didefinisikan dalam perintah select.
      Sintak :
      SELECT SUM (nama_kolom)FROM nama_tabel [WHERE = KONDISI]
      Contoh :
      SELECT SUM (nilai) From mata_pelajaran

      2. Fungsi Waktu


      • GETDATE

      Untuk menampilkan tanggal sekarang
      Contoh :
      SELECT GATEDATE()


      • DATEADD

      Untuk menambah jumlah hari ,tanggal atau tahun yang ditentukan
      Sintak :
      DATEADD(datepart,jumlah,tanggal)
      Contoh :
      SELECT DATEADD(day,10,getdate())
      SELECT DATEADD(Month,10,getdate())
      SELECT DATEADD(year,10,getdate())


      • DATEDIFF

      Untuk mengetahui rentan waktu (bias hari,bulan,tahun)
      Sintak :
      DATEDIFF (datepart,tanggal_awal,tanggal_akhir)
      Contoh :
      SELECT DATEDIFF(month,’01/01/2007’,’01/01/2008)


      • DATENAME

      Untuk menampilkan nama hari,bulan atau tahun
      Sintak :
      DATENAME(detepart,tanggal)
      Contoh :
      SELECT DATENAME(month.getdate()) AS’Bulan sekarang’
      3. Fungsi Aritmatika


      • SQRT

      Untuk mencari akar dari nilai tertentu.
      Contoh :
      SELECT SQRT (100)


      • CEILING

      Untuk pembulatan ke atas dari angka decimal
      Contoh :
      SELECT CEILING(25.25)
      Keterangan : Akan menghasilkan nilai 26


      • FLOOR

      Untuk pembulatan ke bawah dari angka decimal
      Contoh :
      SELECT FLOOR (25.25)
      Keterangan :  Akan menghasilkan nilai 25

      Saturday, April 29, 2017

      Blok Facebook Dengan Layer 7 Di Mikrotik

      Seven - Pada kesempatan kali ini saya ingin membagikan cara Blok Facebook Dengan Layer 7 Di Mikrotik. Tanpa basa-basi langsung saja, pertama tambahkan regexp pada layer7-potocol:
      /ip firewall layer7-protocol add name=fb regexp="^.*(facebook).*$"
      Kemudian tambahkan firewall filter rule:
      /ip firewall filter add chain=forward layer7-protocol=facebook action=drop
      Kemudian coba akses facebook dari pc client dan tada... :D akses ke facebook telah terblokir. Selamat mencoba..

      Note: menggunakan layer7 pada mikrotik akan membuat pemakaian resource/sumber daya menjadi sangat intensif. Dan perlu diperhatikan karena sekarang whatsapp sudah terintegrasi dengan facebook, cara diatas juga akan memblok akses whatsapp. (whatsapp web dalam kasus saya)

      Monday, February 13, 2017

      Konfirgurasi Mikrotik Router Dengan Proxy Eksternal Clear OS


      Seven - Konfirgurasi Mikrotik Router Dengan Proxy Eksternal Clear OS

      Skenario topologi:

      IP Address publik (dari ISP) = 121.122.123.2/30 (hanya contoh)
      IP Address ke jaringan lokal = 192.168.100.0/24
      IP Address ke Clear OS = 192.168.200.1/30

      Konfigurasi:

      NAT

      #NAT ke internet
      /ip firewall nat add chain=srcnat action=masquerade out-interface=publik

      # NAT Clear OS

      /ip firewall nat add chain=dstnat action=dst-nat to-addresses=192.168.200.2 to-ports=3128 protocol=tcp src-address=!192.168.200.1/30 in-interface=local dst-port=80,8080

      # Remot
      Clear OS
      /ip firewall nat add chain=dstnat action=dst-nat to-addresses=192.168.200.2 to-ports=22 protocol=tcp dst-address=121.122.123.2 dst-port=22


      Mangle

      #Marking Hit Loss
      /ip firewall mangle add chain=postrouting action=mark-packet new-packet-mark=hit_loss passthrough=no protocol=tcp dscp=12

      #Marking Koneksi
      /ip firewall mangle add chain=prerouting action=mark-connection new-connection-mark=local_con passthrough=yes src-address=192.168.100.0/24

      #Marking Packet
      /ip firewall mangle add chain=prerouting action=mark-packet new-packet-mark=local_pack passthrough=no connection-mark=
      local_con

      Silahkan dicoba mengakses situs web dan cek apakah settingan sudah berjalan normal.

      Membangun Firewall DMZ Sederhana di Mikrotik

      Seven - Pada kesempatan kali ini Saya akan sharing tentang bagaimana "Membangun Firewall DMZ Sederhana di Mikrotik". Firewall DMZ (Demilitarized Zone) – atau jaringan perimeter adalah jaringan security boundary yang terletak diantara suatu jaringan corporate / private LAN dan jaringan public (Internet).

      Firewall DMZ ini harus dibuat jika anda perlu membuat segmentasi jaringan untuk meletakkan server yang bisa diakses publik dengan aman tanpa harus bisa mengganggu keamanan system jaringan LAN di jaringan private kita. Perimeter (DMZ) network didesain untuk melindungi server pada jaringan LAN corporate dari serangan hackers dari Internet.

      Berikut contoh topologinya:
      Misalnya, IP address WAN/publik pada Mikrotik adalah: 202.162.212.2
      IP address lokal: 192.168.2.1
      IP address web server pada jaringan lokal: 192.168.2.2


      Berikut contoh gambar topologinya:
      dmz topologi - mirzamedia.net


      Berikut konfigurasi pada Mikrotik:

      berikut konfgurasi pada mikrotik:
      konfigurasi ip ether1 WAN: 202.162.212.2
      konfigurasi ip ether2 to web server: 192.168.2.1

      konfigurasi firewall

      ip firewall nat add chain=dstnat action=dst-nat to-addresses=192.168.2.2 to-ports=80 protocol=tcp dst-address=202.162.212.2 dst-port=80


      Selamat mencoba. semoga berhasil!